Tip: Deploying JFDZ from Cassini to IIS

Oct 4, 2009 at 2:14 AM

Note: Below steps are generic, but the details of how to get to the settings are from Server 2k3 (mine is from a WHS)

Being an IIS newb, I found that there are some stumbling blocks moving this to IIS from the casssini (VIsual studio development) environment.  Here are some tips to help out:

1) After moving, ensure you give proper privleges to the app_data folder to allow for IIS to access the database

2) In the web.config, give the application a name (I did this via IIS's settings, on the asp.net tab, slect edit configuration button, Authentication tab -> manage providers button.  Without this entering valid credentials on admin.aspx would bring me right back to the login page.

3) Ensure you select forms auth on step 2

4) Ensure you enable the silverlight mime types (IIS settings, http headers tab, mime types)

5) the sl/out folder needs to have write access enabled for the account that IIS is running under

 

I'll add more as I find them, but this should get people started...

Oct 5, 2009 at 10:31 PM

One more HUGE change that I wasn't aware of..if you deploy this to an IIS 6.0 server..you'll get a bunch of errors when trying to display dynamic content.  Debugging this is a nightmare..as everything will work fine in cassini, but then IIS6.0 will throw exceptions (some of which I wasn't able to catch to examine in VS)

IIS6.0 blocks files without a mime type..and the collection files all have extensions such as .909 and such,though inside they're xml.  So any request done to those files gets you a 404.

This article talks more about the blocking and the workaround (add a * mimetype with application/octet for the type)

http://therightstuff.de/2005/10/23/IIS-And-Unknown-MIME-Types.aspx

This took me 2 days of debugging, rebuilding, and tearing apart to figure out :(